<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>		
	<title>Nvidia Containerizes GPU-Accelerated Deep Learning | Developers | LinuxInsider</title>
	<meta name="title" content="Nvidia Containerizes GPU-Accelerated Deep Learning" />
	<meta name="description" content="We often talk about hybrid cloud business models, but virtually always in the context of traditional processor-bound applications. What if deep learning developers and service operators could run their GPU-accelerated model training or inference delivery service anywhere they wanted? What if they could do so without having to worry about which Nvidia graphics processor unit they were using?" />
	<meta name="keywords" content="Linux" />
	<link rel="shortcut icon" href="/images/lni_favicon.ico" type="image/x-icon" />
	<link rel="alternate" type="application/rss+xml" title="RSS" href="/perl/syndication/rssfull.pl" />
	<meta http-equiv="content-type" content="text/html;charset=ISO-8859-1;" />
	<meta name="viewport" content="width=device-width, maximum-scale=1" />
	
	<link rel="stylesheet" type="text/css" media="screen" href="/shared/general.css" />
	<link rel="stylesheet" type="text/css" media="screen"  title="screensheet" href="/shared/lniscreen.css" />
	<link rel="stylesheet" type="text/css" href="/shared/mobilescreen.css" media="only screen and (max-width:480px)" />
	
	<link rel="alternate stylesheet" type="text/css" media="screen" title="printsheet" href="/shared/print.css" />
	<link rel="stylesheet" type="text/css" media="print"  href="/shared/general.css" />
	<link rel="stylesheet" type="text/css" media="print"  href="/shared/print.css" />
	<link rel="stylesheet" href="/shared/ajax/colorbox/colorbox.css" type="text/css" />
	<link rel="stylesheet" href="/shared/ajax/ui-lightness/jquery-ui-1.10.3.custom.min.css" type="text/css" />
	<link rel="image_src" href="http://www.linuxinsider.com/ai/476253/nvidia-gpu-cloud.jpg" />

	<script type="text/javascript" src="//www.ectnews.com/shared/ajax/jquery-1.11.0.min.js"></script>
	<script type="text/javascript" src="//www.ectnews.com/shared/ajax/jquery-ui-1.10.3.custom.min.js"></script>
	<script type="text/javascript" src="//www.ectnews.com/shared/ajax/colorbox/jquery.colorbox-min.js"></script>
	<script type="text/javascript" src="//www.ectnews.com/shared/general-jquery.js"></script>		<script type="text/javascript"><!--//<![CDATA[
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function() {
      var gads = document.createElement("script");
      gads.async = true;
      gads.type = "text/javascript";
      var useSSL = "https:" == document.location.protocol;
      gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
      var node =document.getElementsByTagName("script")[0];
      node.parentNode.insertBefore(gads, node);
     })();
	//]]>//--></script>
	<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-9357282-4');
	ga('send', 'pageview');
	</script>
</head>
<body>
<div id="fb-root"></div>
<script type="text/javascript"><!--//<![CDATA[
  (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=502379303161829";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));//]]>//--></script>




	<!--ps: 203 crid: 10051:1-all-ec-webdesign-topnav-1 cc:us s_c: px:0-->
	<style type="text/css">
div#tnavad a, div#tnavad a:visited, div#tnavad a:hover { color: #0000ff !important; }
</style>
<div id="tnavad" style="background-color:#f3f3f3;"><a href="http://www.ectnews.com/adsys/link/?crid=10051&amp;ENN_rnd=15100638309942"  >Search and compare Web  Designers and Developers to build, improve or rebrand your website.</a></div>
	<img class="ct-10051-1-all-ec-webdesign-topnav-1" src="/adsys/count/10051/?nm=1-all-ec-webdesign-topnav-1&amp;ENN_rnd=15100638309942&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 203 crid: 10051:1-all-ec-webdesign-topnav-1 cc:us-->
	
<div id="tnav">

	<div id="top-sitelinks" style="float:right">
	<a href="https://www.ecommercetimes.com/">E-BUSINESS</a> | <a href="https://www.technewsworld.com/">TECHNOLOGY</a> | <a href="https://www.crmbuyer.com/">CRM</a> | <a href="https://www.linuxinsider.com/">LINUX</a> | <a href="https://www.ectnews.com/" id="toprow-ennlink">ECTNEWS.COM</a>
	</div>
	
	Welcome Guest | <a href='/perl/User.pl'>Sign In</a>
</div>
<div id="container-outer">
<div id="container">
<script type="text/javascript" language="JavaScript"><!--//<![CDATA[
ENN_site = 'lni';
//]]>//--></script>

<div id="toprow">

	<a href="/"><img src="/images/2013/lni-logo.png" border="0" align="left" alt="LinuxInsider.com" /></a>
	
	<div id="adtitle" class="adtitle" style="padding-top:13px">
	
	<!--ps: 60 crid: 10032:a-nmg_sond_lin_728-1 cc:us s_c:10051 px:0-->
	<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 728x90 - Leaderboard */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 4).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
	<img class="ct-10032-a-nmg_sond_lin_728-1" src="/adsys/count/10032/?nm=a-nmg_sond_lin_728-1&amp;ENN_rnd=15100638306297&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 60 crid: 10032:a-nmg_sond_lin_728-1 cc:us-->
	
	</div>

		
</div>
<div class="printlogo"><a href="/"><img id="printlogo" src="/images/2013/lni-logo.png" border="0" alt="" /></a></div>

<div id="topwrapper">
	<div id="infospace">
	<div class="shim">
	<div id="infoslogo" style="display:none;float:left;">
	<a href="/"><img src="/images/2014/240x40-lni.gif" width="240" height="40" border="0" /></a>
	</div>
	<form class="searchspace" method="get" action="/perl/search.pl" >
	<input type="image" class="searchbutton" src="/images/2014/magnifying-glass_23x19.png" alt="Search" /> <input type="text" id="sitesearch" name="query" class="searchbox" />
	<div class="auto_complete" id="sitesearch_auto_complete"></div>
	</form>
	<a class="infospace-link" href="/perl/section/linux-developer/">Developers</a>
	</div>
	</div>
	<div id="topmenubar">
	<div id="topmenubar-shim" class="shim">
	<ul>
		<li><a href="https://www.linuxinsider.com/perl/section/business_news/">Business</a></li>
	<li><a href="https://www.linuxinsider.com/perl/section/linux-community/">Community</a></li>
	<li><a href="https://www.linuxinsider.com/perl/section/linux-developer/">Developers</a></li>
	<li><a href="https://www.linuxinsider.com/perl/section/linux-enterprise/">Enterprise</a></li>
	<li><a href="https://www.linuxinsider.com/perl/section/mobile/">Mobile</a></li>
	<li><a href="https://www.linuxinsider.com/perl/section/linuxinsider-reviews/">Reviews</a></li>
	<li><a href="https://www.linuxinsider.com/perl/section/open-source-software/">Software</a></li>
	<li><a href="/perl/section/tech-blog/">Tech Blog</a></li>

	<li style="float: right; width: auto;">&nbsp;Reader Services&nbsp;
	<ul>
	<li><a href="https://www.ectnews.com/perl/User.pl">Account Management</a></li>
	<li><a href="https://www.allec.com/">ALL EC Ecommerce Exchange</a></li>
	<li><a href="https://www.ectnews.com/perl/board/mboard.pl">Discussion</a></li>
	<li><a href="https://www.ectnews.com/about/newsalerts/">News Alerts</a></li>
	<li><a href="https://www.ectnews.com/perl/newsletter_registration.pl">Newsletters</a></li>
	<li><a href="/perl/surveys">Reader Surveys</a></li>
	<li><a href="https://www.ectnews.com/about/link-to-us.xhtml#rss">RSS / <img style="vertical-align:middle" src="/images/2004/xml_36x14.gif" border="0" alt='XML' /> Headline Feeds</a></li>
	
	
	
	<li><a href="https://www.ectnews.com/perl/search.pl">Search ECT News Network</a></li>
	<li class="hrule"></li>
	<li><a href="http://www.ectnews.com/about/network_map.xhtml">ECT News Network Map</a>
		<ul>
		<li><a href="https://www.crmbuyer.com/site_map/">CRM Buyer Site Map</a></li>
		<li><a href="https://www.ecommercetimes.com/site_map/">E-Commerce Times Site Map</a></li>
		<li><a href="https://www.linuxinsider.com/site_map/">LinuxInsider Site Map</a></li>
		<li><a href="https://www.technewsworld.com/site_map/">TechNewsWorld Site Map</a></li>
		</ul>
	</li>
	</ul>
</li>


	
	</ul>
	</div>
	</div>
	<script type="text/javascript" language="JavaScript"><!--//<![CDATA[
	new ENN_menu(document.getElementById("topmenubar-shim"));
	//]]>//--></script>
</div>


<div id="middlewrapper">
<div id="breadcrumb">
<!--<div id="snav" style=""><a href="/perl/board/mboard.pl/">DISCUSSION</a> | <a href="/perl/newsletter_registration.pl/">NEWSLETTERS</a> | <a href="http://www.ectnews.com/perl/User.pl/">ACCOUNT MGMT</a></div>-->
<div id="snav" style="">November  7, 2017 06:10:30 AM PST</div>


	<!-- bc -->
	<span id="bcdata">
	<a href="/">LinuxInsider</a> &gt; <a href="/perl/section/linux-developer/">Developers <!--lin--></a>
	|  
	</span>
	<!-- /bc -->
	
</div>
<!-- [% IF !NO_PRINTER_COPYRIGHT %] -->
<script type="text/javascript"><!--//<![CDATA[
document.write('<div class="printer-copyright">');
document.write('Please note that this material is copyright protected. It is illegal to display or reproduce this article without permission for any commercial purpose, including use as marketing or public relations literature. ');
document.write('To obtain reprints of this article for authorized use, please call a sales representative at (818) 461-9700 or visit <a href="http://www.ectnews.com/about/reprints/">http://www.ectnews.com/about/reprints/</a>.');
document.write('</div>');
//]]>//--></script>
<!-- [% END %] -->



<div id="content-main">
	<div class="content-block">
	<!-- content-main -->
	<div id="story">

<h1 class="title">Nvidia Containerizes GPU-Accelerated Deep Learning</h1>
 
<div id="story-byline">
	<!--byline-->By Paul Teich<!--/byline-->
	<br />
	<!--date-->Nov 7, 2017 5:00 AM PT<!--/date-->
	</div>
<script type="text/javascript"><!--//<![CDATA[
	var ENN_sc_u = 'http://www.linuxinsider.com/story/84928.html';
	var ENN_sc_t = 'Nvidia%20Containerizes%20GPU-Accelerated%20Deep%20Learning';
	var ENN_sc_b = 'We%20often%20talk%20about%20hybrid%20cloud%20business%20models,%20but%20virtually%20always%20in%20the%20context%20of%20traditional%20processor-bound%20applications.%20What%20if%20deep%20learning%20developers%20and%20service%20operators%20could%20run%20their%20GPU-accelerated%20model%20training%20or%20inference%20delivery%20service%20anywhere%20they%20wanted%3f%20What%20if%20they%20could%20do%20so%20without%20having%20to%20worry%20about%20which%20Nvidia%20graphics%20processor%20unit%20they%20were%20using%3f';
	ENN_a_sview('paul_teich',84928);
	//]]>//--></script>
<div id="story-graphic-xlarge" style="text-align:center"><img alt="nvidia-gpu-cloud" src="/article_images/story_graphics_xlarge/xl-2017-nvidia-gpu-cloud-1.jpg" width="620" height="410" border="0" /></div>

<div id="story-body"><p class="story-body">We often talk about hybrid cloud business models, but virtually always in the context of traditional processor-bound applications. What if deep learning developers and service operators could run their GPU-accelerated model training or inference delivery service anywhere they wanted?</p>
<p>What if they could do so without having to worry about which Nvidia graphics processor unit they were using, whether their software development environment was complete, or whether their development environment had all the latest updates?</p>
<p>To make that happen, 
<a href="http://Nvidia.com/cloud" target="_blank">Nvidia's GPU Cloud</a>, aka "NGC," pre-integrates all the software pieces into a modern container architecture and certifies a specific configuration for Amazon Web Services. Nvidia will certify configurations for other public clouds in the future.</p>
<p>Nvidia built NGC to address several deep learning challenges. Foremost is that deep learning developers have been having trouble staying current with the latest frameworks and optimizing their frameworks for the GPU hardware they have deployed.</p>
<p>Nvidia has the added challenge of transparently upgrading its current deep learning customers to use Volta's Tensor Core capability as new Volta-based GPU products enter the market.</p>
<p>Tensor Cores gives deep learning developers significantly more performance for matrix math than Nvidia's stock GPU pipelines provide, but developers must know to target Tensor Cores when they are running on Volta GPUs. NGC does that automatically.</p>
<p><div style="text-align:center;">
<iframe width="560" height="315" src="https://www.youtube.com/embed/8xYz46h3MJ0?rel=0" frameborder="0" allowfullscreen></iframe>
</div>

</p>
<h2 class="subhead">
Integration and Tuning 
</h2>
<p>
 
NGC just makes sense. It is a logical extension of 
<a href="https://developer.Nvidia.com/gpu-cloud-images" target="_blank">Nvidia's GPU-accelerated cloud images</a>, which the company developed for internal use in much the same way that AWS and other cloud giants have deployed new services.</p>
<p>Nvidia's own developers were challenged in creating process flows for Nvidia's internal projects. They needed to cope with the complexity of maintaining optimized versions of multiple deep learning frameworks. Different frameworks serve different applications and markets -- including drones, autonomous cars and trucks, internal chip development simulations, etc.</p>
<p>NGC is not a simple aggregation of deep learning software development tools and frameworks in a container. There are several key components to NGC -- Nvidia GPU drivers, the container, development tools, CUDA runtimes, Nvidia libraries, configuration files, environment variables, configuration management and certification.</p>
<p>All of these components are important for Nvidia to deliver NGC as a turnkey service on multiple public clouds. Plus, given the rapidly evolving state of deep learning tools, Nvidia has committed to upgrade and recertify its NGC container images on a monthly schedule.
Nvidia initially will tune, test and certify NGC to work with 
<a href="https://aws.amazon.com/about-aws/whats-new/2017/10/introducing-amazon-ec2-p3-instances/" target="_blank">Amazon EC2 P3</a> instances using Nvidia Tesla V100 GPUs, and with 
<a href="https://www.Nvidia.com/en-us/data-center/dgx-systems/" target="_blank">Nvidia's DGX Systems</a> using Nvidia Tesla P100 and V100 GPUs.</p>
<p>Nvidia's certification provides a guarantee that all the solution components are integrated properly and tuned for the best possible performance. There are other deep learning instances available in the AWS Marketplace, but they are not tuned, tested, updated or certified by Nvidia.</p>
<p><hr noshade="noshade" size="1" />
<div style="width:620px; float:none; margin: 10px auto;"
class="story-thumbnail">
<a href="/article_images/2017/84928_970x790.jpg" class="lightview"
title="::::topclose:true"><img
src="/article_images/2017/84928_620x505-small.jpg" alt="NGC Containers
using AWS" /></a>
<div style="text-align:left;font-size:15px;padding-top:8px;">NGC's simple
Web interface shows its supported deep learning frameworks. (Click image
to enlarge.)</div>
</div>
<hr noshade="noshade" size="1" /> 

</p>
<h2 class="subhead">
Nvidia-Docker Project
</h2>
<p>

Two years ago, Nvidia open-sourced its development project to containerize its CUDA software development environment plus runtime OS, executables and libraries for Nvidia GPUs. The result is the 
<a href="https://github.com/Nvidia/Nvidia-docker" target="_blank">GitHub project named "Nvidia-docker"</a> (version 1.0.1 was released in March 2017 and 
<a href="https://github.com/Nvidia/Nvidia-docker/tree/2.0" target="_blank">version 2.0 is now in alpha test</a>). Nvidia sometimes refers to Nvidia-docker as "nv-docker," but they are the same thing.</p>
<p>Scaling from an on-prem PC or workstation to an on-prem Nvidia DGX-Station or DGX-1 server (from a single GPU card to clusters of eight NVLink-connected Pascal or Volta GPUs chips) is possible by starting with the open source Nvidia-docker distribution and then moving to a certified NGC instance. 
</p>
<h2 class="subhead"></h2>
<p>
Scaling from on-prem to public cloud can be done in the same manner. The biggest change in moving from Nvidia-docker to NGC is that Nvidia maintains NGC docker images for developers instead of developers having to update their own Nvidia-docker images.</p>
<p>Microsoft may be next in supporting NGC on Azure. There is an 
<a href="https://github.com/Nvidia/Nvidia-docker/wiki/Deploy-on-Azure" target="_blank">Azure deployment thread</a> in the Nvidia-docker repository. The deployment thread is based on 
<a href="https://azure.microsoft.com/en-us/pricing/details/virtual-machines/series/#n-series" target="_blank">Azure's N-Series</a> virtual machine. Given that Nvidia already has positioned NGC as multicloud, well... we'll see what the future holds.</p>
<p>First, Microsoft would have to announce a new N-Series VM based on Nvidia's Volta products. Microsoft previewed Azure's 
<a href="https://azure.microsoft.com/en-us/pricing/details/virtual-machines/linux/" target="_blank">NCv2 instance using Nvidia's P100 GPUs</a>. Further, Azure is mentioned in its 
<a href="https://devtalk.Nvidia.com/default/topic/1025613/faq/commonly-asked-questions-and-answers/" target="_blank">NGC Users FAQ</a>, so it's not a stretch to expect V100 VMs in the not-too-distant future. Nvidia then would have to certify a known good configuration of Nvidia-docker for Azure.</p>
<p>The Nvidia-docker project also provides limited build support for IBM's Power architecture. Given 
<a href="https://www.forbes.com/sites/tiriasresearch/2017/09/21/ibm-and-Nvidia-power-new-scale-out-gear-for-ai/" target="_blank">IBM's work in scaling Nvidia GPU cluster performance</a>, Nvidia-docker support might create interesting options for GPU containers in the OpenPOWER ecosystem in 2018.


</p>
<h2 class="subhead">
DIY Developer-Friendly
</h2>
<p>

The Nvidia-docker container runs on x86 host instances using Ubuntu 16.04 and CentOS 7 OSes. Nvidia developed host OS drivers that can run multiple virtual GPU images, so that a single-host OS can manage multiple containers virtually, accessing multiple GPU chips across many GPU sockets or add-in cards.</p>
<p><hr noshade="noshade" size="1" />
<div style="width:620px; float:none; margin: 10px auto;"
class="story-thumbnail">
<a href="/article_images/2017/84928_965x467.jpg" class="lightview"
title="::::topclose:true"><img
src="/article_images/2017/84928_620x300-small.jpg" alt="NGC deep learning
frameworks" /></a>
<div style="text-align:left;font-size:15px;padding-top:8px;">NGC starts
with Nvidia Docker and then adds everything needed to run a large
selection of deep learning frameworks. (Click image to enlarge.)</div>
</div>
<hr noshade="noshade" size="1" /></p>
<p>NGC initially supports most major deep learning training frameworks: Caffe/Caffe2, CNTK, MXNet, Torch, PyTorch, TensorFlow and Theano. Trained models can be loaded into Nvidia's 
<a href="https://developer.Nvidia.com/tensorrt" target="_blank">TensorRT</a> for inferencing.</p>
<p>The open source version of NGC's underlying containers and the developer tools are available to anyone running at least an Nvidia Titan-level GPU card and a Linux host operating system. This allows do-it-yourself developers with large local datasets, security or compliance concerns to begin developing deep learning models on prem, with the pre-integrated open source version on PCs and workstations. These DIY developers then can migrate to Nvidia's certified instances on major public clouds as their needs grow.</p>
<p>The opposite migration also can happen. Some deep learning developers may start by using public cloud instances, but as their utilization rates and cloud service costs rise, they might invest in dedicated infrastructure to bring their workload on prem.</p>
<p>NGC will not allow customers to use their optimized NGC containers with custom high-performance computing GPU clusters. However, HPC customers are much more likely to customize Nvidia-docker instances for their specific hardware architectures.</p>
<p>NGC is intended to streamline deep learning development on widely available Nvidia-accelerated system configurations spanning desktop to public cloud.
<img src="//www.ectnews.com/images/end-enn.gif" width="21" height="10" border="0" />


</p>
<hr noshade="noshade" size="1" /><p id="story-authorbio"><img src="/images/rws481594/Paul Teich.jpg" align="left" />
<strong>Paul Teich</strong> has been an ECT News Network columnist since 2017. He is a partner and principal analyst at Tirias Research with more than 35 years of high-tech industry experience. His focus is on product development and corporate strategy, including intellectual property planning and evaluation for processors; System on Chip; system architecture roadmaps and product definition; firmware and software development for embedded systems; system level and applications programming; and user experience development for PCs, workstations and servers. Teich's background includes two 10-year stints at AMD. He became an analyst in 2012 as CTO and senior analyst at Moor Insights & Strategy. <a href="mailto:paul@tiriasresearch.com">Email Paul.</a><br clear="all" />
</p></div>

</div>

<hr noshade="noshade" size="1" />


		
		<style>
		#shareleft { display: absolute; position: fixed; top: 250px; margin-left: -125px; }
		.st_twitter_hcount, .st_facebook_hcount, .st_linkedin_hcount, .st_plusone_hcount,.st_sharethis_hcount, .st_pinterest_hcount, .st_stumbleupon_hcount {
			display: block;
			margin-bottom: 15px;
		}
		.st_plusone_hcount { margin-left: 3px }
		</style>
		<script type="text/javascript" src="https://ws.sharethis.com/button/buttons.js"></script>
		<script type="text/javascript">stLight.options({publisher:'aa1224c6-b198-4ba7-8912-a0e9e2e5e489', mobileWidget: "true", doNotCopy: "true"});</script>

		<div id="shareleft" style="margin-bottom: 10px">
		<span class="st_plusone_hcount" displayText="+1" st_url="https://www.linuxinsider.com/story/84928.html" st_title="Nvidia Containerizes GPU-Accelerated Deep Learning"></span>
		<span class="st_twitter_hcount" displayText="Tweet" st_url="https://www.linuxinsider.com/story/84928.html" st_title="Nvidia Containerizes GPU-Accelerated Deep Learning" st_via="technewsworld"></span>
		<span class="st_facebook_hcount" displayText="Share" st_url="https://www.linuxinsider.com/story/84928.html" st_title="Nvidia Containerizes GPU-Accelerated Deep Learning"></span>
		<span class="st_linkedin_hcount"  st_url="https://www.linuxinsider.com/story/84928.html" st_title="Nvidia Containerizes GPU-Accelerated Deep Learning"></span>
		<span class="st_stumbleupon_hcount" displayText="Share" st_url="https://www.linuxinsider.com/story/84928.html" st_title="Nvidia Containerizes GPU-Accelerated Deep Learning"></span>
		<span class="st_sharethis_hcount" displayText="Share" st_url="https://www.linuxinsider.com/story/84928.html" st_title="Nvidia Containerizes GPU-Accelerated Deep Learning"></span>
		</div>	
		<!--<div style="position:absolute;right:0px;bottom:100px" class="fb-like" data-href="https://www.linuxinsider.com/story/84928.html" data-send="false" data-layout="button_count" data-width="450" data-show-faces="true" data-font="verdana"></div>-->
		
		
		<p id="story-toolbox2">
		
		<div id="cccperms">
		<div style="margin-bottom: 10px;height:18px; line-height:18px;">
		<a target="_blank" href="http://www.copyright.com/OpenURL/?sid=Pub_LinuxInsider&servicename=all&issn=4780030&date=2007&WT.mc_id=Pub_LinuxInsider"><img style="vertical-align:middle; margin-right: 5px;" width="16" height="18" border="0" src="/images/2013/ccc-button.png" />Get Permission to License or Reproduce this Article</a>
		</div>
		<span style="white-space: nowrap;"><img src="/images/work/icon_print_20x14.gif" alt="" width="20" height="14" border="0" /><a href="#" class="printtext tool-print" title="Print" onclick="ENN_print_toggle(this);return false;">Print</a></span>
<span style="white-space: nowrap;"><img src="/images/work/icon_send_20x14.gif" alt="" width="20" height="14" border="0" /><a class="tool-email" href="/perl/mailit/?id=84928">Email</a></span>
<span style="white-space: nowrap;"><img src="/images/2006/icon_reprint_20x14.gif" alt="" width="20" height="14" border="0" /><a href="http://www.ectnews.com/about/reprints.xhtml">Reprints</a></span>
<span style="white-space: nowrap;"><img src="/images/work/icon_search_20x14.gif" alt="" width="20" height="14" border="0" /><a href="#searchbyline">More by Paul Teich</a></span></div></p>
 
 
<div class="story-advertisement-2">
	<!--ps: 122 crid: 10033:a-nmg_sond_lin_300-1 cc:us s_c:10032,10051 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
</div>
	<img class="ct-10033-a-nmg_sond_lin_300-1" src="/adsys/count/10033/?nm=a-nmg_sond_lin_300-1&amp;ENN_rnd=15100638301637&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 122 crid: 10033:a-nmg_sond_lin_300-1 cc:us-->
	</div>
 
 
 
 	<!--/content-block-->
	</div>
<!--/content-main-->
</div>

<div id="content-nav">
	<div id="share">
		<table cellpadding="0" cellspacing="0" border="0" width="100%">
		<tr>
		<td align="center" valign="top"><a href="https://www.facebook.com/ectnews" target="_blank"><img src="/images/2015/navicon-facebook_32x32.png" width="32 height="32" border="0" alt="Facebook" /></a></td>
		<td align="center" valign="top"><a href="https://www.twitter.com/technewsworld" target="_blank"><img src="/images/2015/navicon-twitter_32x32.png" width="32 height="32" border="0" alt="Twitter" /></a></td>
		<td align="center" valign="top"><a href="http://www.linkedin.com/company/ect-news-network" target="_blank"><img src="/images/2015/navicon-linkedin_32x32.png" width="32 height="32" border="0" alt="LinkedIn" /></a></td>
		<td align="center" valign="top"><a href="https://plus.google.com/108979104378490788701/posts" target="_blank"><img src="/images/2015/navicon-googleplus_32x32.png" width="32 height="32" border="0" alt="Google+" /></a></td>
		<td align="center" valign="top"><a href="http://www.stumbleupon.com/submit" onclick="ENN_wo('http://www.stumbleupon.com/submit?url=' + (typeof ENN_sc_u != 'undefined' ? ENN_sc_u : document.location.href)); return false;" target="_blank"><img src="/images/2015/navicon-stumbleupon_32x32.png" width="32 height="32" border="0" /></a></td>
		<td align="center" valign="top"><a href="http://www.ectnews.com/about/link-to-us.xhtml#rss" target="_blank"><img src="/images/2015/navicon-rss_32x32.png" width="32 height="32" border="0" alt="RSS" /></a></td>
		</tr></table>
	</div>
	<div id="shortcuts" class="content-block">
		<div class="headline-item">
		<table cellpadding="0" cellspacing="0" border="0" width="100%" height="14"><tr><td align="left"><img src="//www.ectnews.com/images/2015/icon_mostpop_14x14roundcorner.png" width="14" height="14" border="0" /> <a class="headline" href="/perl/mostpop/">Most Popular</a></td><td align="center"><img src="//www.ectnews.com/images/2012/icon_newsletter_16x12.png" width="16" height="12" border="0" /> <a class="headline" href="http://www.ectnews.com/perl/newsletter_registration.pl">Newsletters</a></td><td align="right"><img src="//www.ectnews.com/images/2012/icon_alert_14x14.png" width="14" height="14" border="0" /> <a class="headline" href="http://www.ectnews.com/about/newsalerts/">News Alerts</a></td></tr></table>
		</div>
		<!--
		<div class="headline-item">
		<a class="headline" href="/perl/mostpop/">Most Popular</a> <span style="font-size:10px;">|</span> <a class="headline" href="http://www.ectnews.com/oneweek/network.xhtml" >This Week on ECT News Network</a>
		</div>
		-->
	</div>

	
	
	
	<!--rnd: 0--1.77936135138264 -->
	
	<div class="right-bb">
	
	<!--ps: 112 crid: 10065:1-allec_contmkt_300-1rt cc:us s_c:10032,10033,10051 px:0-->
	<div class="bbframe"><a href="" onclick=" { ENN_ad_wo(10065,'15100638308862','http://www.ectnews.com/'); return false; }" onmouseover="status='https://www.allec.com/content-marketing-25off-fp?utm_source=ectnn&amp;utm_medium=300x250rc&amp;utm_campaign=contentmarketing&amp;utm_content=25off'; return true;" onmouseout="status=''; return true;"   ><img src="/images/sda/allec_contentmarketing_25off_300x250.jpg" width="300" height="250" border="0" alt="Content Marketing on ALL EC" /></a></div>
	<img class="ct-10065-1-allec_contmkt_300-1rt" src="/adsys/count/10065/?nm=1-allec_contmkt_300-1rt&amp;ENN_rnd=15100638308862&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 112 crid: 10065:1-allec_contmkt_300-1rt cc:us-->
	
	</div>
	
	

			
			<div class="survey" style="border: solid 1px #cbcbcb">
			<div class="survey-description" style="background-color:#eeeeee;font-weight:bold">Which method of communication do you consider most important?</div>
			<div class="survey-body" style="padding:5px">
			<form>
			<input type="hidden" name="survey_id" value="141" />
			<table>
			
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="783" /></td><td>voice calls</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="784" /></td><td>video calls</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="785" /></td><td>snail mail</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="786" /></td><td>email</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="787" /></td><td>text messages</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="788" /></td><td>online chat</td>
				</tr>
		
			</table>
			<div class="survey-vote"><button onclick="return ENN_vote(this.form)">Vote to See Results</button></div>
			</form>
			</div>
			</div>
			
	
	<div class="content-tab border-ect"><a class="content-block-intro" href="http://www.ecommercetimes.com/">E-Commerce Times</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-84934">
			<a href="http://www.ecommercetimes.com/story/84934.html" >The Long Black Friday Shopping Day Has Dawned</a>
			</div>
			

			<div class="headline-item" id="rhd-84931">
			<a href="http://www.ecommercetimes.com/story/84931.html" >IBM Launches Private Cloud to Ease Public Cloud Transition</a>
			</div>
			

			<div class="headline-item" id="rhd-84930">
			<a href="http://www.ecommercetimes.com/story/84930.html" >The Eve of the Self-Driving Revolution</a>
			</div>
			

			<div class="headline-item" id="rhd-84924">
			<a href="http://www.ecommercetimes.com/story/84924.html" >6 Ways E-Commerce SMBs Can Offer Great Customer Service on a Tight Budget</a>
			</div>
			

			<div class="headline-item" id="rhd-84920">
			<a href="http://www.ecommercetimes.com/story/84920.html" >Amazon May Disrupt Prescription Drug Space Next</a>
			</div>
			

			<div class="headline-item" id="rhd-84912">
			<a href="http://www.ecommercetimes.com/story/84912.html" >New Search Tool Helps Firms Find the Best B2B Software Fit</a>
			</div>
			

			<div class="headline-item" id="rhd-84911">
			<a href="http://www.ecommercetimes.com/story/84911.html" >Amazon to Let Delivery Drivers Open Your Front Door</a>
			</div>
			

			<div class="headline-item" id="rhd-84909">
			<a href="http://www.ecommercetimes.com/story/84909.html" >Taking the News Out of Facebook's News Feed Could Hurt Publishers</a>
			</div>
			
	</div>

	<div class="right-bb">
	
	<!--ps: 68 crid: 10033:a-nmg_sond_lin_300-1 cc:us s_c:10032,10065,10033,10051 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
</div>
	<img class="ct-10033-a-nmg_sond_lin_300-1" src="/adsys/count/10033/?nm=a-nmg_sond_lin_300-1&amp;ENN_rnd=15100638304562&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 68 crid: 10033:a-nmg_sond_lin_300-1 cc:us-->
	
	</div>
	
	<div class="content-tab border-tnw"><a class="content-block-intro" href="http://www.technewsworld.com/">TechNewsWorld</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-84927">
			<a href="http://www.technewsworld.com/story/84927.html" >Dilbert vs. Trump: Why False Facts Have Power</a>
			</div>
			

			<div class="headline-item" id="rhd-84933">
			<a href="http://www.technewsworld.com/story/84933.html" >Call of Duty WWII Kicks Off Holiday Season With a Bang</a>
			</div>
			

			<div class="headline-item" id="rhd-84932">
			<a href="http://www.technewsworld.com/story/84932.html" >Razer Debuts Cutting-Edge Mobile Gaming Phone</a>
			</div>
			

			<div class="headline-item" id="rhd-84929">
			<a href="http://www.technewsworld.com/story/84929.html" >Sony's Aibo Resurrected From Robot Pet Cemetery</a>
			</div>
			

			<div class="headline-item" id="rhd-84925">
			<a href="http://www.technewsworld.com/story/84925.html" >iPhone X Delivers on Apple's Promises and That's Plenty, Say Reviewers</a>
			</div>
			

			<div class="headline-item" id="rhd-84919">
			<a href="http://www.technewsworld.com/story/84919.html" >Neural Nets Give Low-End Phone Pics DSLR Look</a>
			</div>
			

			<div class="headline-item" id="rhd-84915">
			<a href="http://www.technewsworld.com/story/84915.html" >Fake News: Amazon Wants a Key to Your House</a>
			</div>
			

			<div class="headline-item" id="rhd-84918">
			<a href="http://www.technewsworld.com/story/84918.html" >Super Mario Odyssey Has Reviewers Jumping for Joy</a>
			</div>
			
	</div>

	<div class="right-bb">
	
	<!--ps: 113 crid: 10033:a-nmg_sond_lin_300-1 cc:us s_c:10032,10065,10033,10051 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
</div>
	<img class="ct-10033-a-nmg_sond_lin_300-1" src="/adsys/count/10033/?nm=a-nmg_sond_lin_300-1&amp;ENN_rnd=15100638306215&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 113 crid: 10033:a-nmg_sond_lin_300-1 cc:us-->
	
	</div>

	<div class="content-tab border-cad"><a class="content-block-intro" href="http://www.crmbuyer.com/">CRM Buyer</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-84935">
			<a href="http://www.crmbuyer.com/story/84935.html" >5 Innovative Ways to Inspire Customer Loyalty</a>
			</div>
			

			<div class="headline-item" id="rhd-84922">
			<a href="http://www.crmbuyer.com/story/84922.html" >New Relationship Marketing Hub Aims to Goose Conversion Rates</a>
			</div>
			

			<div class="headline-item" id="rhd-84921">
			<a href="http://www.crmbuyer.com/story/84921.html" >Oil Patch CRM</a>
			</div>
			

			<div class="headline-item" id="rhd-84917">
			<a href="http://www.crmbuyer.com/story/84917.html" >With Gamification, CRM Is a Brand New Ball Game</a>
			</div>
			

			<div class="headline-item" id="rhd-84907">
			<a href="http://www.crmbuyer.com/story/84907.html" >AI Integrations Help Sort Out Sales Signals</a>
			</div>
			

			<div class="headline-item" id="rhd-84898">
			<a href="http://www.crmbuyer.com/story/84898.html" >Email Marketing Goes Hand-in-Glove With E-Commerce Shipping</a>
			</div>
			

			<div class="headline-item" id="rhd-84897">
			<a href="http://www.crmbuyer.com/story/84897.html" >Counting Down to ASC 606</a>
			</div>
			

			<div class="headline-item" id="rhd-84893">
			<a href="http://www.crmbuyer.com/story/84893.html" >Accenture, SAP Plot One CX Platform for All</a>
			</div>
			
	</div>
	
	
	<!--ps: 170 crid: 3217:a_sponsored_links cc:us s_c:10032,10065,10033,10051 px:0-->
	
<!-- slinks -->
	<div class="content-tab-slinks">SPONSOR SHOWCASE</div>
	<div class="content-block-slinks">

				<div class="slink-title">Content Marketers - Save 25%</div>
				<div class="slink-text"><a href="" onclick=" { ENN_ad_wo(10064,'15100638301268'); return false; }" onmouseover="status='https://www.allec.com/content-marketing-25off-fp?utm_source=ectnn&amp;utm_medium=sponsoredlink&amp;utm_campaign=contentmarketing&amp;utm_content=25off'; return true;" onmouseout="status=''; return true;"  ><img src="/images/sda/allec_logo_60x60.png" width="60" height="60" border="0" align="right" />
A well-executed content marketing strategy can help attract targeted traffic to your website. Publish your company's blog, videos, events and more on ALL EC. View Offer.</a><img class="ct-10064-1-allec_contmkt_stl-1" src="/adsys/count/10064/?nm=1-allec_contmkt_stl-1&amp;ENN_rnd=15100638301268&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" /></div>
				

				<div class="slink-title">Future Digital Finance West | Dec 4-5</div>
				<div class="slink-text"><a href="" onclick=" { ENN_ad_wo(10023,'15100638301268'); return false; }" onmouseover="status='https://www.allec.com/events/future-digital-finance-west-70?utm_source=ectnews&amp;utm_medium=stl&amp;utm_campaign=wbr&amp;utm_content=fdfw'; return true;" onmouseout="status=''; return true;"  ><img src="/images/sda/wbr_60x60.jpg" width="60" height="60" border="0" align="right" />
A conference for digital finance innovators who are paving the way forward at America's largest financial institutions. 25% discount to finance execs. View agenda and learn more.</a><img class="ct-10023-1-all_ec_wbrfdfw_stl-1" src="/adsys/count/10023/?nm=1-all_ec_wbrfdfw_stl-1&amp;ENN_rnd=15100638301268&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" /></div>
				

				<div class="slink-title">Deluxe Social Media Management Services</div>
				<div class="slink-text"><a href="" onclick=" { ENN_ad_wo(10000,'15100638301268'); return false; }" onmouseover="status='http://www.shareasale.com/r.cfm?B=931279&amp;U=1533249&amp;M=19875&amp;urllink='; return true;" onmouseout="status=''; return true;"  ><img src="/images/sda/deluxe_60x60.png" width="60" height="60" border="0" align="right" />
We create, manage, and report on your social media presence. Engage your audience. Maximize your reach. Learn more.</a><img class="ct-10000-a-sas-deluxe-stl-1" src="/adsys/count/10000/?nm=a-sas-deluxe-stl-1&amp;ENN_rnd=15100638301268&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" /></div>
				

				<div class="slink-title">Marketers - Fill Your Sales Funnel Instantly</div>
				<div class="slink-text"><a href="" onclick=" { ENN_ad_wo(8781,'15100638301268'); return false; }" onmouseover="status='/shared/sales/ECTNEWS-INSTA-LEADS-DECK.pdf'; return true;" onmouseout="status=''; return true;"  ><img src="/images/sda/sales-funnel_60x60.jpg" width="60" height="60" border="0" align="right" />
Access millions of  IT and business decision makers. Our full-service global marketing program delivers sales-ready leads. Learn more.</a><img class="ct-8781-1-instaleads-stl-1" src="/adsys/count/8781/?nm=1-instaleads-stl-1&amp;ENN_rnd=15100638301268&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" /></div>
				
	</div>
<!-- /slinks -->

	<img class="ct-3217-a_sponsored_links" src="/adsys/count/3217/?nm=a_sponsored_links&amp;ENN_rnd=15100638301268&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 170 crid: 3217:a_sponsored_links cc:us-->
	
	
	<div class="hslice" id="lniheadlines"><a rel="feedurl" href="/shared_cs/navsliceupdate.xhtml" style="display:none;"></a><div class="entry-title" style="display:none">LinuxInsider Headlines</div>

	<div class="content-tab border-lni"><a class="content-block-intro" href="http://www.linuxinsider.com/">LinuxInsider</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-84926">
			<a href="http://www.linuxinsider.com/story/84926.html" >New Collaborative Platform to Spur Open Source AI Development</a>
			</div>
			

			<div class="headline-item" id="rhd-84923">
			<a href="http://www.linuxinsider.com/story/84923.html" >Sonar Could Help Devs Build a Better Website</a>
			</div>
			

			<div class="headline-item" id="rhd-84914">
			<a href="http://www.linuxinsider.com/story/84914.html" >AWS Offers Aurora Cloud DB Service Compatible With PostgreSQL</a>
			</div>
			

			<div class="headline-item" id="rhd-84903">
			<a href="http://www.linuxinsider.com/story/84903.html" >Linux Foundation Launches Open Data Licensing Agreements</a>
			</div>
			

			<div class="headline-item" id="rhd-84901">
			<a href="http://www.linuxinsider.com/story/84901.html" >Anarchy Linux Dispels Fear of Arch</a>
			</div>
			

			<div class="headline-item" id="rhd-84896">
			<a href="http://www.linuxinsider.com/story/84896.html" >Samsung to Give Linux Desktop Experience to Smartphone Users</a>
			</div>
			

			<div class="headline-item" id="rhd-84890">
			<a href="http://www.linuxinsider.com/story/84890.html" >Companies Turn Blind Eye to Open Source Security Risks</a>
			</div>
			

			<div class="headline-item" id="rhd-84881">
			<a href="http://www.linuxinsider.com/story/84881.html" >AWS, Microsoft Offer New Open Source AI Framework</a>
			</div>
			
	</div>

	</div>
	
	<div class="right-bb">
	
	<!--ps: 125 crid: 9887:a-ox_lin_600-1na cc:us s_c:10032,3217,10065,10033,10051 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
if (!window.OX_ads) { OX_ads = []; }
OX_ads.push({ "auid" : "538762542" });
//]]>//--></script>
<script type="text/javascript"><!--//<![CDATA[
document.write('<scr'+'ipt src="//us-ads.openx.net/w/1.0/jstag"><\/scr'+'ipt>');
//]]>//--></script>
<noscript><iframe id="c66eb4ec61" name="c66eb4ec61" src="//us-ads.openx.net/w/1.0/afr?auid=538762542&amp;cb=15100638309205" frameborder="0" scrolling="no" width="300" height="600"><a href="//us-ads.openx.net/w/1.0/rc?cs=c66eb4ec61&amp;cb=15100638309205" ><img src="//us-ads.openx.net/w/1.0/ai?auid=538762542&amp;cs=c66eb4ec61&amp;cb=15100638309205" border="0" alt="" /></a></iframe></noscript>
</div>
	<img class="ct-9887-a-ox_lin_600-1na" src="/adsys/count/9887/?nm=a-ox_lin_600-1na&amp;ENN_rnd=15100638309205&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 125 crid: 9887:a-ox_lin_600-1na cc:us-->
	
	</div>

	
<!--/content-nav-->
</div>


</div>



<div id="content-bottom">

<a name="inside-site"></a>

	
	<div id="lb2">
	
	<!--ps: 21 crid: 10032:a-nmg_sond_lin_728-1 cc:us s_c:9887,10032,3217,10065,10033,10051 px:0-->
	<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 728x90 - Leaderboard */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 4).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
	<img class="ct-10032-a-nmg_sond_lin_728-1" src="/adsys/count/10032/?nm=a-nmg_sond_lin_728-1&amp;ENN_rnd=15100638307397&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 21 crid: 10032:a-nmg_sond_lin_728-1 cc:us-->
	
	</div>
	



	
	
	<div id="lb3" class="lb2">
	
	<!--ps: 163 crid: 10032:a-nmg_sond_lin_728-1 cc:us s_c:9887,10032,3217,10065,10033,10051 px:0-->
	<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 728x90 - Leaderboard */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 4).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
	<img class="ct-10032-a-nmg_sond_lin_728-1" src="/adsys/count/10032/?nm=a-nmg_sond_lin_728-1&amp;ENN_rnd=15100638301257&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 163 crid: 10032:a-nmg_sond_lin_728-1 cc:us-->
	
	</div>
	


</div>
</div>
</div>

<div id="footer-container">
<div id="footer">

	<table class="headlines-section publication-info">
	<tr>
	<td valign="top"><div><a href="https://www.ectnews.com/about/advertising/#publications">Publications</a></div>
	<ul>
	<li><a class="headline" href="https://www.allec.com/">ALL EC</a></li>
	<li><a class="headline" href="https://www.crmbuyer.com/">CRM Buyer</a></li>
	<li><a class="headline" href="https://www.ecommercetimes.com/">E-Commerce Times</a></li>
	<li><a class="headline" href="https://www.linuxinsider.com/">LinuxInsider</a></li>
	<li><a class="headline" href="https://www.technewsworld.com/">TechNewsWorld</a></li>

	</ul>
	<div id="bottom-logo" style="position: absolute;width:455px; height:125px; margin-top:10px"><a href="https://www.ectnews.com/"><img src="/images/2013/enn-logo-bottom.png" align="left" width="455" height="125" border="0" style="margin-left: -5px;" alt="ECT News Network" /></a></div>

	</td>
	<td valign="top" style="padding-left:50px"><div><a href="https://www.ectnews.com/perl/newsletter_registration.pl">Newsletters</a></div>
	<ul>
	<li><a class="headline" href="https://www.ectnews.com/perl/newsletter_registration.pl" onclick='window.open("https://www.ecommercetimes.com/perl/nwsltrdisp.pl?n=ect_daily","_blank","resizable=yes,menubar=yes,location=no,toolbar=no,scrollbars=yes,status=no,directories=no,width=650,height=400"); return false;'>E-Commerce Minute</a></li>
	<li><a class="headline" href="https://www.ectnews.com/perl/newsletter_registration.pl" onclick='window.open("https://www.technewsworld.com/perl/nwsltrdisp.pl?n=tnw_daily","_blank","resizable=yes,menubar=yes,location=no,toolbar=no,scrollbars=yes,status=no,directories=no,width=650,height=400"); return false;'>Tech News Flash</a></li>
	<li><a class="headline" href="https://www.ectnews.com/perl/newsletter_registration.pl" onclick='window.open("https://www.ectnews.com/perl/nwsltrdisp.pl?n=enn_weekly","_blank","resizable=yes,menubar=yes,location=no,toolbar=no,scrollbars=yes,status=no,directories=no,width=650,height=400"); return false;'>ECT News Network Weekly</a></li>
	<li><a class="headline" href="https://www.ectnews.com/perl/newsletter_registration.pl" onclick='window.open("http://www.ectnews.com/perl/nwsltrdisp.pl?n=edpick_alert","_blank","resizable=yes,menubar=yes,location=no,toolbar=no,scrollbars=yes,status=no,directories=no,width=650,height=400"); return false;'>Editor's Pick</a></li>
	<li><a class="headline" href="https://www.ectnews.com/perl/newsletter_registration.pl">Subscribe</a></li>
	</ul>
	</td>

	<td valign="top">
	<div>Reader Services</div>
	<ul>
	<li><a class="headline" href="https://www.ectnews.com/perl/User.pl">Account Management</a></li>
	<li><a class="headline" href="https://www.ectnews.com/perl/board/mboard.pl">Discussion</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/link-to-us.xhtml">Linking Policy</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/network_map.xhtml">Network Map</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/newsalerts/">News Alerts</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/link-to-us.xhtml#rss">RSS / XML Feeds</a></li>
	<li><a class="headline" href="https://www.ectnews.com/perl/search.pl">Search ECT News Network</a></li>
	</ul>
	<table cellpadding="0" cellspacing="0" border="0">
		<tr>
		<td><a href="https://www.facebook.com/ectnews" target="_blank"><img src="/images/2013/navicon-facebook_20x20-gray.png" width="20" height="20" border="0" alt="Facebook" /></a></td>
		<td><a href="https://www.twitter.com/technewsworld" target="_blank"><img src="/images/2013/navicon-twitter_20x20-gray.png" width="20" height="20" border="0" alt="Twitter" /></a></td>
		<td><a href="http://www.linkedin.com/company/ect-news-network" target="_blank"><img src="/images/2013/navicon-linkedin_20x20-gray.png" width="20" height="20" border="0" alt="LinkedIn" /></a></td>
		<td><a href="https://plus.google.com/108979104378490788701/posts" target="_blank"><img src="/images/2013/navicon-googleplus_20x20-gray.png" width="20" height="20" border="0" alt="Google+" /></a></td>
		<td><a href="http://www.stumbleupon.com/submit" onclick="ENN_wo('http://www.stumbleupon.com/submit?url=' + (typeof ENN_sc_u != 'undefined' ? ENN_sc_u : document.location.href)); return false;" target="_blank"><img src="/images/2013/navicon-stumbleupon_20x20-gray.png" width="20" height="20" border="0" /></a></td>
		<td><a href="http://www.ectnews.com/about/link-to-us.xhtml#rss" target="_blank"><img src="/images/2013/navicon-rss_20x20-gray.png" width="20" height="20" border="0" alt="RSS" /></a></td>
		</tr>
	</table>
	</td>
	<td valign="top" style="padding-left:10px"><div>Company Info</div>
	<ul>
	<li><a class="headline" href="https://www.ectnews.com/about/">About</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/advertising/">Advertising</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/bizdev.xhtml">Business Development</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/careers.xhtml">Careers</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/#contact">Contact</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/permissions.xhtml">Permissions</a></li>
	<li><a class="headline" href="https://www.ectnews.com/about/reprints/">Reprint Information</a></li>
	</ul>
	</td>
	</tr>
	</table>
	<div id="bottom-copyright">
		<div style="float:right;">
		<a class="bottom-copyright" href="https://www.ectnews.com/about/terms-of-service.xhtml">Terms of Service</a> | <a class="bottom-copyright" href="https://www.ectnews.com/about/privacy.xhtml">Privacy Policy</a> | <a class="bottom-copyright" href="http://www.ectnews.com/about/advertising/">How To Advertise</a>
		</div>
		Copyright 1998-2017 ECT News Network, Inc. All Rights Reserved.

	</div>
</div>
</div>






<script type="text/javascript">
	(function(){
		window._pxAppId ='PXeL3l4XIH';
		// Custom parameters
		// window._pxParam1 = "<param1>";
		var p = document.getElementsByTagName('script')[0],
			s = document.createElement('script');
		s.async = 1;
		s.src = '//client.perimeterx.net/PXeL3l4XIH/main.min.js';
		p.parentNode.insertBefore(s,p);
	}());
</script>
<div style="position:fixed; top:0; left:0;" width="1" height="1">
	<img src="//collector-PXeL3l4XIH.perimeterx.net/api/v1/collector/pxPixel.gif?appId=PXeL3l4XIH">
	<!-- With custom parameters: -->
	<!--<img src="//collector-PXeL3l4XIH.perimeterx.net/api/v1/collector/pxPixel.gif?appId=PXeL3l4XIH&p1=VALUE&p2=VALUE2&p3=VALUE3">-->
</div>
<noscript>
	<div style="position:fixed; top:0; left:0;" width="1" height="1">
		<img src="//collector-PXeL3l4XIH.perimeterx.net/api/v1/collector/noScript.gif?appId=PXeL3l4XIH">
	</div>
</noscript>
</body>
</html>
