<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en">
<head>		
	<title>With the Shell, You Can Go Wild(card) and Follow Your Pipe Dream | Software | LinuxInsider</title>
	<meta name="title" content="With the Shell, You Can Go Wild(card) and Follow Your Pipe Dream" />
	<meta name="description" content="There is more to the shell than commands composed of alphanumeric characters. In addition to those familiar programs, there is a whole host of processing tools hiding behind the symbols of a standard keyboard. To say nothing of their incredible potency in combination, each one is so powerful on its own that it helps to take a methodical approach to get familiar with them." />
	<meta name="keywords" content="Linux" />
	<link rel="shortcut icon" href="/images/lni_favicon.ico" type="image/x-icon" />
	<link rel="alternate" type="application/rss+xml" title="RSS" href="/perl/syndication/rssfull.pl" />
	<meta http-equiv="content-type" content="text/html;charset=ISO-8859-1;" />
	<meta name="viewport" content="width=device-width, maximum-scale=1" />
	
	<link rel="stylesheet" type="text/css" media="screen" href="/shared/general.css" />
	<link rel="stylesheet" type="text/css" media="screen"  title="screensheet" href="/shared/lniscreen.css" />
	<link rel="stylesheet" type="text/css" href="/shared/mobilescreen.css" media="only screen and (max-width:480px)" />
	
	<link rel="alternate stylesheet" type="text/css" media="screen" title="printsheet" href="/shared/print.css" />
	<link rel="stylesheet" type="text/css" media="print"  href="/shared/general.css" />
	<link rel="stylesheet" type="text/css" media="print"  href="/shared/print.css" />
	<link rel="stylesheet" href="/shared/ajax/colorbox/colorbox.css" type="text/css" />
	<link rel="stylesheet" href="/shared/ajax/ui-lightness/jquery-ui-1.10.3.custom.min.css" type="text/css" />
	<link rel="image_src" href="http://www.linuxinsider.com/ai/978229/terminal-shell.jpg" />

	<script type="text/javascript" src="//www.ectnews.com/shared/ajax/jquery-1.11.0.min.js"></script>
	<script type="text/javascript" src="//www.ectnews.com/shared/ajax/jquery-ui-1.10.3.custom.min.js"></script>
	<script type="text/javascript" src="//www.ectnews.com/shared/ajax/colorbox/jquery.colorbox-min.js"></script>
	<script type="text/javascript" src="//www.ectnews.com/shared/general-jquery.js"></script>		<script type="text/javascript"><!--//<![CDATA[
    var googletag = googletag || {};
    googletag.cmd = googletag.cmd || [];
    (function() {
      var gads = document.createElement("script");
      gads.async = true;
      gads.type = "text/javascript";
      var useSSL = "https:" == document.location.protocol;
      gads.src = (useSSL ? "https:" : "http:") + "//www.googletagservices.com/tag/js/gpt.js";
      var node =document.getElementsByTagName("script")[0];
      node.parentNode.insertBefore(gads, node);
     })();
	//]]>//--></script>
	<script>
	(function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
	(i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
	m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
	})(window,document,'script','//www.google-analytics.com/analytics.js','ga');
	ga('create', 'UA-9357282-4');
	ga('send', 'pageview');
	</script>
</head>
<body>
<div id="fb-root"></div>
<script type="text/javascript"><!--//<![CDATA[
  (function(d, s, id) {
  var js, fjs = d.getElementsByTagName(s)[0];
  if (d.getElementById(id)) return;
  js = d.createElement(s); js.id = id;
  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1&appId=502379303161829";
  fjs.parentNode.insertBefore(js, fjs);
}(document, 'script', 'facebook-jssdk'));//]]>//--></script>




	<!--ps: 203 crid: 10045:1-all-ec-ai-topnav-1 cc:us s_c: px:0-->
	<style type="text/css">
div#tnavad a, div#tnavad a:visited, div#tnavad a:hover { color: #0000ff !important; }
</style>
<div id="tnavad" style="background-color:#f3f3f3;"><a href="http://www.ectnews.com/adsys/link/?crid=10045&amp;ENN_rnd=15073286381481"  >Find and compare the best Artificial Intelligence software for your business.</a></div>
	<img class="ct-10045-1-all-ec-ai-topnav-1" src="/adsys/count/10045/?nm=1-all-ec-ai-topnav-1&amp;ENN_rnd=15073286381481&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 203 crid: 10045:1-all-ec-ai-topnav-1 cc:us-->
	
<div id="tnav">

	<div id="top-sitelinks" style="float:right">
	<a href="http://www.ecommercetimes.com/">E-BUSINESS</a> | <a href="http://www.technewsworld.com/">TECHNOLOGY</a> | <a href="http://www.crmbuyer.com/">CRM</a> | <a href="http://www.linuxinsider.com/">LINUX</a> | <a href="http://www.ectnews.com/" id="toprow-ennlink">ECTNEWS.COM</a>
	</div>
	
	Welcome Guest | <a href='/perl/User.pl'>Sign In</a>
</div>
<div id="container-outer">
<div id="container">
<script type="text/javascript" language="JavaScript"><!--//<![CDATA[
ENN_site = 'lni';
//]]>//--></script>

<div id="toprow">

	<a href="/"><img src="/images/2013/lni-logo.png" border="0" align="left" alt="LinuxInsider.com" /></a>
	
	<div id="adtitle" class="adtitle" style="padding-top:13px">
	
	<!--ps: 60 crid: 10032:a-nmg_sep_lin_728-1 cc:us s_c:10045 px:0-->
	<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 728x90 - Leaderboard */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 4).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
	<img class="ct-10032-a-nmg_sep_lin_728-1" src="/adsys/count/10032/?nm=a-nmg_sep_lin_728-1&amp;ENN_rnd=15073286384584&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 60 crid: 10032:a-nmg_sep_lin_728-1 cc:us-->
	
	</div>

		
</div>
<div class="printlogo"><a href="/"><img id="printlogo" src="/images/2013/lni-logo.png" border="0" alt="" /></a></div>

<div id="topwrapper">
	<div id="infospace">
	<div class="shim">
	<div id="infoslogo" style="display:none;float:left;">
	<a href="/"><img src="/images/2014/240x40-lni.gif" width="240" height="40" border="0" /></a>
	</div>
	<form class="searchspace" method="get" action="/perl/search.pl" >
	<input type="image" class="searchbutton" src="/images/2014/magnifying-glass_23x19.png" alt="Search" /> <input type="text" id="sitesearch" name="query" class="searchbox" />
	<div class="auto_complete" id="sitesearch_auto_complete"></div>
	</form>
	<a class="infospace-link" href="/perl/section/open-source-software/">Software</a>
	</div>
	</div>
	<div id="topmenubar">
	<div id="topmenubar-shim" class="shim">
	<ul>
		<li><a href="http://www.linuxinsider.com/perl/section/business_news/">Business</a></li>
	<li><a href="http://www.linuxinsider.com/perl/section/linux-community/">Community</a></li>
	<li><a href="http://www.linuxinsider.com/perl/section/linux-developer/">Developers</a></li>
	<li><a href="http://www.linuxinsider.com/perl/section/linux-enterprise/">Enterprise</a></li>
	<li><a href="http://www.linuxinsider.com/perl/section/mobile/">Mobile</a></li>
	<li><a href="http://www.linuxinsider.com/perl/section/linuxinsider-reviews/">Reviews</a></li>
	<li><a href="http://www.linuxinsider.com/perl/section/open-source-software/">Software</a></li>
	<li><a href="/perl/section/tech-blog/">Tech Blog</a></li>

	<li style="float: right; width: auto;">&nbsp;Reader Services&nbsp;
	<ul>
	<li><a href="http://www.ectnews.com/perl/User.pl">Account Management</a></li>
	<li><a href="http://www.ectnews.com/perl/board/mboard.pl">Discussion</a></li>
	
	<li><a href="http://www.ectnews.com/about/newsalerts/">News Alerts</a></li>
	<li><a href="http://www.ectnews.com/perl/newsletter_registration.pl">Newsletters</a></li>
	<li><a href="/perl/surveys">Reader Surveys</a></li>
	<li><a href="http://www.ectnews.com/about/link-to-us.xhtml#rss">RSS / <img style="vertical-align:middle" src="/images/2004/xml_36x14.gif" border="0" alt='XML' /> Headline Feeds</a></li>
	
	
	
	<li><a href="http://www.ectnews.com/perl/search.pl">Search ECT News Network</a></li>
	<li class="hrule"></li>
	<li><a href="http://www.ectnews.com/about/network_map.xhtml">ECT News Network Map</a>
		<ul>
		<li><a href="http://www.crmbuyer.com/site_map/">CRM Buyer Site Map</a></li>
		<li><a href="http://www.ecommercetimes.com/site_map/">E-Commerce Times Site Map</a></li>
		<li><a href="http://www.linuxinsider.com/site_map/">LinuxInsider Site Map</a></li>
		<li><a href="http://www.technewsworld.com/site_map/">TechNewsWorld Site Map</a></li>
		</ul>
	</li>
	</ul>
</li>


	
	</ul>
	</div>
	</div>
	<script type="text/javascript" language="JavaScript"><!--//<![CDATA[
	new ENN_menu(document.getElementById("topmenubar-shim"));
	//]]>//--></script>
</div>


<div id="middlewrapper">
<div id="breadcrumb">
<!--<div id="snav" style=""><a href="/perl/board/mboard.pl/">DISCUSSION</a> | <a href="/perl/newsletter_registration.pl/">NEWSLETTERS</a> | <a href="http://www.ectnews.com/perl/User.pl/">ACCOUNT MGMT</a></div>-->
<div id="snav" style="">October  6, 2017 03:23:58 PM PDT</div>


	<!-- bc -->
	<span id="bcdata">
	<a href="/">LinuxInsider</a> &gt; <a href="/perl/section/open-source-software/">Software <!--lin--></a>
	|  
	</span>
	<!-- /bc -->
	
</div>
<!-- [% IF !NO_PRINTER_COPYRIGHT %] -->
<script type="text/javascript"><!--//<![CDATA[
document.write('<div class="printer-copyright">');
document.write('Please note that this material is copyright protected. It is illegal to display or reproduce this article without permission for any commercial purpose, including use as marketing or public relations literature. ');
document.write('To obtain reprints of this article for authorized use, please call a sales representative at (818) 461-9700 or visit <a href="http://www.ectnews.com/about/reprints/">http://www.ectnews.com/about/reprints/</a>.');
document.write('</div>');
//]]>//--></script>
<!-- [% END %] -->



<div id="content-main">
	<div class="content-block">
	<!-- content-main -->
	<div id="story">

<h1 class="title">With the Shell, You Can Go Wild(card) and Follow Your Pipe Dream</h1>
 
<div id="story-byline">
	<!--byline-->By Jonathan Terrasi<!--/byline-->
	<br />
	<!--date-->Oct 6, 2017 2:21 PM PT<!--/date-->
	</div>
<script type="text/javascript"><!--//<![CDATA[
	var ENN_sc_u = 'http://www.linuxinsider.com/story/84863.html';
	var ENN_sc_t = 'With%20the%20Shell,%20You%20Can%20Go%20Wild(card)%20and%20Follow%20Your%20Pipe%20Dream';
	var ENN_sc_b = 'There%20is%20more%20to%20the%20shell%20than%20commands%20composed%20of%20alphanumeric%20characters.%20In%20addition%20to%20those%20familiar%20programs,%20there%20is%20a%20whole%20host%20of%20processing%20tools%20hiding%20behind%20the%20symbols%20of%20a%20standard%20keyboard.%20To%20say%20nothing%20of%20their%20incredible%20potency%20in%20combination,%20each%20one%20is%20so%20powerful%20on%20its%20own%20that%20it%20helps%20to%20take%20a%20methodical%20approach%20to%20get%20familiar%20with%20them.';
	ENN_a_sview('jonathan_terrasi',84863);
	//]]>//--></script>
<div id="story-graphic-xlarge" style="text-align:center"><img alt="linux-terminal" data-c="a" src="/article_images/story_graphics_xlarge/xl-2017-linux-terminal-1.jpg" width="620" height="360" border="0" />
<div class="graphic-credit"><img src="/images/2015/image-credit-adobe-stock_130x15.gif" alt="" /></div>
</div>

<div id="story-body"><p class="story-body">There is more to the shell, the terminal's interpreter software, than commands composed of alphanumeric characters. In addition to those familiar programs, there is a whole host of processing tools hiding behind the symbols of a standard keyboard.</p>
<p>To say nothing of their incredible potency in combination, each one is so powerful on its own that it helps to take a methodical approach to get familiar with them. With that in mind, I'll narrow the focus here to two of the more practical symbols: the pipe ("|") and the wildcard ("*").</p>
<p>To illustrate the versatility of these two shell tools, I'll use one in-depth example: locating settings in the configuration directory for a package manager. 

</p>
<h2 class="subhead">
Spring Cleaning
</h2>
<p>

The package manager is pretty straightforward, as it is the program that determines how your system's packages -- the bundles programs come in -- are installed, updated and removed. Without it, you would be unable to install new software, and your system would not stay updated or even run, as programs would be missing key libraries needed to execute properly.</p>
<p>So, what is a configuration directory? While programs traditionally read all their settings from a single configuration file, many newer applications have a directory (usually ending in ".d") that acts as one big configuration, with each individual file as a subsection.</p>
<p>This approach makes the configuration more modular, letting users add or remove components simply by creating and deleting the respective files. However, it makes it harder to scan through the composite directory-wide configuration for particular settings.</p>
<p>Let's say we are running a Debian-based distribution, like Ubuntu, and we want to search through the configuration for our package manager, "apt", which utilizes a configuration directory dividing its configuration into files in the "/etc/apt/apt.conf.d" directory.</p>
<p>One reason we might need to search these settings could be to determine how many old packages our system is holding onto, especially if our system has been installed for a while.</p>
<p>For troubleshooting purposes, Linux systems keep copies of old packages in case users need to revert to them after unstable updates. With stable systems like Ubuntu, though, a more likely problem is that too many backups of large packages -- the Linux kernel being a usual suspect -- fill up the small slice of the system where boot data is stored.</p>
<p>To solve this problem, we'll need to find the setting for how many package versions of programs get cached -- a daunting prospect when presented with more than a dozen files in "/etc/apt/apt.conf.d".</p>
<p>This is where our two new tools come in. 

</p>
<h2 class="subhead">
The Wildcard
</h2>
<p>

Represented by the asterisk symbol, the wildcard allows the shell to process multiple files at the same time. When used in conjunction with a command that takes a file as an argument, a lone wildcard is treated by the shell as all the files residing in the current directory.</p>
<p>The shell accomplishes this using a process called "expansion" -- essentially, in the background, the shell replaces the "*" with the names of every file in the current directory.</p>
<p>In our kernel-caching scenario, we will want to start by examining the contents of every configuration directory file. Displaying the contents of each file one at a time would be time-consuming, but with the wildcard and the "cat" command, we can return all of them at once, simply by giving "*" rather than a filename in the target directory as an argument to "cat" (following a space):</p>
<p>$ cat /etc/apt/apt.conf.d/*</p>
<p>This is a good first step, but it's hard to skim through so much information in the disorderly command return. That's where our second tool comes in. 

</p>
<h2 class="subhead">
The Pipe
</h2>
<p>

The pipe is a simple shell component that sits between two commands and sends the output of one command to the input of the next. A sequence of commands that includes one or more pipes is called a "pipeline," and a single pipeline can be as simple as two commands -- for example, the time-honored construct of sending the output of information-displaying commands into a viewer program like "less".</p>
<p>As the name suggests, a viewer program is one whose primary application is to let you view data, and it differs from an editor in that it won't let you edit anything. When dealing with critical settings like those of a package manager, this limitation is greatly beneficial.</p>
<p>We can take the data aggregation of our "cat" command and alloy it with the organization of "less" by constructing a pipeline, in which "cat /etc/apt/apt.conf.d/*" and "less" are separated by the "|" (with a space on either side):</p>
<p>$ cat /etc/apt/apt.conf.d/* | less</p>
<p>Our settings are neatly collected in a viewer, but although our pipe to "less" allows us to scroll through the settings, there's still a lot to scan. We can pare down the amount of data to look over by applying our wildcard to Linux's powerful search tool, "grep".</p>
<p>The "grep" command takes a search term, which in our case is "cache," and (optionally) a file to be searched as space-separated arguments. By giving "cache" as our search and "/etc/apt/apt.conf.d/*" as our file, we can sift through all the files at once:</p>
<p>$ grep cache /etc/apt/apt.conf.d/*</p>
<p>Now we've got a manageable amount of information to scan through, but we're back to reading it in the terminal's standard output. Having "less" to view these search results would be convenient, and by reintroducing our pipe to "less", we can do just that:</p>
<p>$ grep cache /etc/apt/apt.conf.d/* | less</p>
<p>This gives us both the reduced output of matched settings and the neat layout of a viewer. Pipelines that feed into "less" are the most prevalent, but you can pipe any command that prints to the terminal's standard output into any command that accepts input from the user (standard input) or from a file. 

</p>
<h2 class="subhead">
Homing In
</h2>
<p>

Often in configuration directories, filenames start with a two-digit number, with the program loading them in numerical order. So what if we wanted to search only the first files to be loaded, those prepended with "00"?</p>
<p>If a wildcard precedes or follows alphanumeric characters with no space, it will restrict the possible matches from all files to files that end or begin with the specified alphanumeric characters, respectively.</p>
<p>In our example, if we re-run our previous command with "00" after the slash but before the wildcard, "grep" will only search through files starting with "00":</p>
<p>$ grep cache /etc/apt/apt.conf.d/00*</p>
<p>Conversely, if we want to find only files that end with the word "upgrade," we can remove the "00" and follow the wildcard with "upgrade":</p>
<p>$ grep cache /etc/apt/apt.conf.d/*upgrade</p>
<p>Used separately or in combination, pipes and wildcards can increase your productivity dramatically by giving you the power to narrow or expand the scope of data as needed.</p>
<p>You might even find that these data processing tricks can help you solve a recurring problem in ways you didn't expect. Either way, taking both of these for a test drive is the best way to see what they can do.
<img src="//www.ectnews.com/images/end-enn.gif" width="21" height="10" border="0" />


</p>
<hr noshade="noshade" size="1" /><p id="story-authorbio">
<strong>Jonathan Terrasi</strong> has been an ECT News Network columnist since 2017. His main interests are computer security (particularly with the Linux desktop), encryption, and analysis of politics and current affairs. He is a full-time freelance writer and musician. His background includes providing technical commentaries and analyses in articles published by the Chicago Committee to Defend the Bill of Rights.<br clear="all" />
</p></div>

</div>

<hr noshade="noshade" size="1" />


		
		<style>
		#shareleft { display: absolute; position: fixed; top: 250px; margin-left: -125px; }
		.st_twitter_hcount, .st_facebook_hcount, .st_linkedin_hcount, .st_plusone_hcount,.st_sharethis_hcount, .st_pinterest_hcount, .st_stumbleupon_hcount {
			display: block;
			margin-bottom: 15px;
		}
		.st_plusone_hcount { margin-left: 3px }
		</style>
		<script type="text/javascript" src="//w.sharethis.com/button/buttons.js"></script>
		<script type="text/javascript">stLight.options({publisher:'aa1224c6-b198-4ba7-8912-a0e9e2e5e489', mobileWidget: "true", doNotCopy: "true"});</script>

		<div id="shareleft" style="margin-bottom: 10px">
		<span class="st_plusone_hcount" displayText="+1" st_url="http://www.linuxinsider.com/story/84863.html" st_title="With the Shell, You Can Go Wild(card) and Follow Your Pipe Dream"></span>
		<span class="st_twitter_hcount" displayText="Tweet" st_url="http://www.linuxinsider.com/story/84863.html" st_title="With the Shell, You Can Go Wild(card) and Follow Your Pipe Dream" st_via="technewsworld"></span>
		<span class="st_facebook_hcount" displayText="Share" st_url="http://www.linuxinsider.com/story/84863.html" st_title="With the Shell, You Can Go Wild(card) and Follow Your Pipe Dream"></span>
		<span class="st_linkedin_hcount"  st_url="http://www.linuxinsider.com/story/84863.html" st_title="With the Shell, You Can Go Wild(card) and Follow Your Pipe Dream"></span>
		<span class="st_stumbleupon_hcount" displayText="Share" st_url="http://www.linuxinsider.com/story/84863.html" st_title="With the Shell, You Can Go Wild(card) and Follow Your Pipe Dream"></span>
		<span class="st_sharethis_hcount" displayText="Share" st_url="http://www.linuxinsider.com/story/84863.html" st_title="With the Shell, You Can Go Wild(card) and Follow Your Pipe Dream"></span>
		</div>	
		<!--<div style="position:absolute;right:0px;bottom:100px" class="fb-like" data-href="http://www.linuxinsider.com/story/84863.html" data-send="false" data-layout="button_count" data-width="450" data-show-faces="true" data-font="verdana"></div>-->
		
		
		<p id="story-toolbox2">
		
		<div id="cccperms">
		<div style="margin-bottom: 10px;height:18px; line-height:18px;">
		<a target="_blank" href="http://www.copyright.com/OpenURL/?sid=Pub_LinuxInsider&servicename=all&issn=4780030&date=2007&WT.mc_id=Pub_LinuxInsider"><img style="vertical-align:middle; margin-right: 5px;" width="16" height="18" border="0" src="/images/2013/ccc-button.png" />Get Permission to License or Reproduce this Article</a>
		</div>
		<span style="white-space: nowrap;"><img src="/images/work/icon_print_20x14.gif" alt="" width="20" height="14" border="0" /><a href="#" class="printtext tool-print" title="Print" onclick="ENN_print_toggle(this);return false;">Print</a></span>
<span style="white-space: nowrap;"><img src="/images/work/icon_send_20x14.gif" alt="" width="20" height="14" border="0" /><a class="tool-email" href="/perl/mailit/?id=84863">Email</a></span>
<span style="white-space: nowrap;"><img src="/images/2006/icon_reprint_20x14.gif" alt="" width="20" height="14" border="0" /><a href="http://www.ectnews.com/about/reprints.xhtml">Reprints</a></span>
<span style="white-space: nowrap;"><img src="/images/work/icon_search_20x14.gif" alt="" width="20" height="14" border="0" /><a href="#searchbyline">More by Jonathan Terrasi</a></span></div></p>
 
 
<div class="story-advertisement-2">
	<!--ps: 122 crid: 9876:a-zip-1us cc:us s_c:10032,10045 px:0-->
	<div style="border: solid 1px;color:#cccccc;padding:10px;">
<div style="text-align:left;color:#7a73ce;font-size:18px;font-weight:bold;">FIND YOUR FUTURE JOB HERE</div>
<div id="zipsearch_container" style="text-align:left">
<a href="https://www.ziprecruiter.com" id="jobs_widget_link"><span>Job Search by</span> 
<span id="zr_logo_container"><img id="zr_logo" src="https://www.ziprecruiter.com/img/ziprecruiter-logo-200px.png" 
alt="ZipRecruiter" width="100" /></span></a> 
</div> 
<script type="text/javascript" src="https://www.ziprecruiter.com/jobs-widget/pro/v2/fvg5iu5zhxprp7azczny54yspdag2f98"><!--//<![CDATA[//]]>//--></script> 
<script type="text/javascript"><!--//<![CDATA[ 
var options = { 
container : "zipsearch_container", 
jobs_per_page : '5', 
}; 
zipsearch.init(options); 
//]]>//--></script>
</div>
	<img class="ct-9876-a-zip-1us" src="/adsys/count/9876/?nm=a-zip-1us&amp;ENN_rnd=15073286382779&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 122 crid: 9876:a-zip-1us cc:us-->
	
	<span class="pid" id="pid122" title="1:24"></span></div>
 
 
 
 	<!--/content-block-->
	</div>
<!--/content-main-->
</div>

<div id="content-nav">
	<div id="share">
		<table cellpadding="0" cellspacing="0" border="0" width="100%">
		<tr>
		<td align="center" valign="top"><a href="https://www.facebook.com/ectnews" target="_blank"><img src="/images/2015/navicon-facebook_32x32.png" width="32 height="32" border="0" alt="Facebook" /></a></td>
		<td align="center" valign="top"><a href="https://www.twitter.com/technewsworld" target="_blank"><img src="/images/2015/navicon-twitter_32x32.png" width="32 height="32" border="0" alt="Twitter" /></a></td>
		<td align="center" valign="top"><a href="http://www.linkedin.com/company/ect-news-network" target="_blank"><img src="/images/2015/navicon-linkedin_32x32.png" width="32 height="32" border="0" alt="LinkedIn" /></a></td>
		<td align="center" valign="top"><a href="https://plus.google.com/108979104378490788701/posts" target="_blank"><img src="/images/2015/navicon-googleplus_32x32.png" width="32 height="32" border="0" alt="Google+" /></a></td>
		<td align="center" valign="top"><a href="http://www.stumbleupon.com/submit" onclick="ENN_wo('http://www.stumbleupon.com/submit?url=' + (typeof ENN_sc_u != 'undefined' ? ENN_sc_u : document.location.href)); return false;" target="_blank"><img src="/images/2015/navicon-stumbleupon_32x32.png" width="32 height="32" border="0" /></a></td>
		<td align="center" valign="top"><a href="http://www.ectnews.com/about/link-to-us.xhtml#rss" target="_blank"><img src="/images/2015/navicon-rss_32x32.png" width="32 height="32" border="0" alt="RSS" /></a></td>
		</tr></table>
	</div>
	<div id="shortcuts" class="content-block">
		<div class="headline-item">
		<table cellpadding="0" cellspacing="0" border="0" width="100%" height="14"><tr><td align="left"><img src="//www.ectnews.com/images/2015/icon_mostpop_14x14roundcorner.png" width="14" height="14" border="0" /> <a class="headline" href="/perl/mostpop/">Most Popular</a></td><td align="center"><img src="//www.ectnews.com/images/2012/icon_newsletter_16x12.png" width="16" height="12" border="0" /> <a class="headline" href="http://www.ectnews.com/perl/newsletter_registration.pl">Newsletters</a></td><td align="right"><img src="//www.ectnews.com/images/2012/icon_alert_14x14.png" width="14" height="14" border="0" /> <a class="headline" href="http://www.ectnews.com/about/newsalerts/">News Alerts</a></td></tr></table>
		</div>
		<!--
		<div class="headline-item">
		<a class="headline" href="/perl/mostpop/">Most Popular</a> <span style="font-size:10px;">|</span> <a class="headline" href="http://www.ectnews.com/oneweek/network.xhtml" >This Week on ECT News Network</a>
		</div>
		-->
	</div>

	
	
	
	<!--rnd: 0--8.45685125665739 -->
	
	<div class="right-bb">
	
	<!--ps: 112 crid: 10033:a-nmg_sep_lin_300-1 cc:us s_c:10032,9876,10045 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
</div>
	<img class="ct-10033-a-nmg_sep_lin_300-1" src="/adsys/count/10033/?nm=a-nmg_sep_lin_300-1&amp;ENN_rnd=15073286387278&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 112 crid: 10033:a-nmg_sep_lin_300-1 cc:us-->
	
	</div>
	
	

			
			<div class="survey" style="border: solid 1px #cbcbcb">
			<div class="survey-description" style="background-color:#eeeeee;font-weight:bold">What are the best uses of smart home speakers like Amazon's Echo and Google's Home?</div>
			<div class="survey-body" style="padding:5px">
			<form>
			<input type="hidden" name="survey_id" value="136" />
			<table>
			
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="751" /></td><td>Answering questions through artificial intelligence software.</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="752" /></td><td>Streaming music or video content.</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="753" /></td><td>Managing other smart home technologies, like lights.</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="754" /></td><td>Maintaining shopping and to do lists.</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="755" /></td><td>Setting timers, reminders and alarms.</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="756" /></td><td>Ordering takeout, transportation or products.</td>
				</tr>
		
				<tr class="survey-opt" style="">
				<td valign="top"><input type="radio" name="opt_id" value="757" /></td><td>Communicating with family and friends.</td>
				</tr>
		
			</table>
			<div class="survey-vote"><button onclick="return ENN_vote(this.form)">Vote to See Results</button></div>
			</form>
			</div>
			</div>
			
	
	<div class="content-tab border-ect"><a class="content-block-intro" href="http://www.ecommercetimes.com/">E-Commerce Times</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-84862">
			<a href="http://www.ecommercetimes.com/story/84862.html" >HPE Gave Russia Deep Dive Into Security Software Used by Pentagon</a>
			</div>
			

			<div class="headline-item" id="rhd-84858">
			<a href="http://www.ecommercetimes.com/story/84858.html" >Are You Ready for a RoboCEO?</a>
			</div>
			

			<div class="headline-item" id="rhd-84856">
			<a href="http://www.ecommercetimes.com/story/84856.html" >3 Timely E-Commerce Shipping Tips</a>
			</div>
			

			<div class="headline-item" id="rhd-84852">
			<a href="http://www.ecommercetimes.com/story/84852.html" >'Invisible' Technologies: What You Can't See Can Hurt You</a>
			</div>
			

			<div class="headline-item" id="rhd-84849">
			<a href="http://www.ecommercetimes.com/story/84849.html" >Google Adds a Brick to Online Publishers' Paywalls</a>
			</div>
			

			<div class="headline-item" id="rhd-84841">
			<a href="http://www.ecommercetimes.com/story/84841.html" >Amazon Deploys Army of Echoes Against Oncoming Threats</a>
			</div>
			

			<div class="headline-item" id="rhd-84843">
			<a href="http://www.ecommercetimes.com/story/84843.html" >Cloudflare Stream Promises Easy, Cheap Video Hosting</a>
			</div>
			

			<div class="headline-item" id="rhd-84838">
			<a href="http://www.ecommercetimes.com/story/84838.html" >Behind-the-Scenes Cryptocurrency Mining Discovered on Showtime Sites</a>
			</div>
			
	</div>

	<div class="right-bb">
	
	<!--ps: 68 crid: 9888:a-ox_lin_300-1na cc:us s_c:10032,9876,10045,10033 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
if (!window.OX_ads) { OX_ads = []; }
OX_ads.push({ "auid" : "538762530" });
//]]>//--></script>
<script type="text/javascript"><!--//<![CDATA[
document.write('<scr'+'ipt src="//us-ads.openx.net/w/1.0/jstag"><\/scr'+'ipt>');
//]]>//--></script>
<noscript><iframe id="3e794f3d19" name="3e794f3d19" src="//us-ads.openx.net/w/1.0/afr?auid=538762530&amp;cb=15073286383513" frameborder="0" scrolling="no" width="300" height="250"><a href="//us-ads.openx.net/w/1.0/rc?cs=3e794f3d19&amp;cb=15073286383513" ><img src="//us-ads.openx.net/w/1.0/ai?auid=538762530&amp;cs=3e794f3d19&amp;cb=15073286383513" border="0" alt="" /></a></iframe></noscript>
</div>
	<img class="ct-9888-a-ox_lin_300-1na" src="/adsys/count/9888/?nm=a-ox_lin_300-1na&amp;ENN_rnd=15073286383513&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 68 crid: 9888:a-ox_lin_300-1na cc:us-->
	
	</div>
	
	<div class="content-tab border-tnw"><a class="content-block-intro" href="http://www.technewsworld.com/">TechNewsWorld</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-84861">
			<a href="http://www.technewsworld.com/story/84861.html" >Gadget Ogling: Same Old Apple</a>
			</div>
			

			<div class="headline-item" id="rhd-84857">
			<a href="http://www.technewsworld.com/story/84857.html" >AI Ripples Through Google's New Product Lineup</a>
			</div>
			

			<div class="headline-item" id="rhd-84850">
			<a href="http://www.technewsworld.com/story/84850.html" >Roku Sets Up New Streaming Player Buffet</a>
			</div>
			

			<div class="headline-item" id="rhd-84854">
			<a href="http://www.technewsworld.com/story/84854.html" >Google Poised to Add New Pixels to Growing Ecosystem</a>
			</div>
			

			<div class="headline-item" id="rhd-84853">
			<a href="http://www.technewsworld.com/story/84853.html" >iOS Users May Regret Going to 11</a>
			</div>
			

			<div class="headline-item" id="rhd-84840">
			<a href="http://www.technewsworld.com/story/84840.html" >Anticipating the Smart World of 2027: A Billion Cameras and AI, Oh My...</a>
			</div>
			

			<div class="headline-item" id="rhd-84846">
			<a href="http://www.technewsworld.com/story/84846.html" >Google Assistant Goes to Work for Nvidia's Shield TV</a>
			</div>
			

			<div class="headline-item" id="rhd-84842">
			<a href="http://www.technewsworld.com/story/84842.html" >Twitter to Test Drive Double-Wide Tweets</a>
			</div>
			
	</div>

	<div class="right-bb">
	
	<!--ps: 113 crid: 10033:a-nmg_sep_lin_300-1 cc:us s_c:10032,9888,9876,10045,10033 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
</div>
	<img class="ct-10033-a-nmg_sep_lin_300-1" src="/adsys/count/10033/?nm=a-nmg_sep_lin_300-1&amp;ENN_rnd=15073286383997&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 113 crid: 10033:a-nmg_sep_lin_300-1 cc:us-->
	
	</div>

	<div class="content-tab border-cad"><a class="content-block-intro" href="http://www.crmbuyer.com/">CRM Buyer</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-84855">
			<a href="http://www.crmbuyer.com/story/84855.html" >Show Season</a>
			</div>
			

			<div class="headline-item" id="rhd-84848">
			<a href="http://www.crmbuyer.com/story/84848.html" >New BPM, CRM Features Aim to Speed Strategy Execution</a>
			</div>
			

			<div class="headline-item" id="rhd-84844">
			<a href="http://www.crmbuyer.com/story/84844.html" >Digital Hub Returns</a>
			</div>
			

			<div class="headline-item" id="rhd-84839">
			<a href="http://www.crmbuyer.com/story/84839.html" >New Cloud Tools Aim to Streamline, Monetize Partner Relationships</a>
			</div>
			

			<div class="headline-item" id="rhd-84835">
			<a href="http://www.crmbuyer.com/story/84835.html" >Einstein Tries Sales Forecasting</a>
			</div>
			

			<div class="headline-item" id="rhd-84828">
			<a href="http://www.crmbuyer.com/story/84828.html" >Nimble's Social CRM Finds Its Way Into Office 365</a>
			</div>
			

			<div class="headline-item" id="rhd-84825">
			<a href="http://www.crmbuyer.com/story/84825.html" >Finally Oracle</a>
			</div>
			

			<div class="headline-item" id="rhd-84817">
			<a href="http://www.crmbuyer.com/story/84817.html" >New Mobile App Promises Full B2B E-Commerce Experience</a>
			</div>
			
	</div>
	
	
	<!--ps: 170 crid: 3217:a_sponsored_links cc:us s_c:10032,9888,9876,10045,10033 px:0-->
	
<!-- slinks -->
	<div class="content-tab-slinks">SPONSOR SHOWCASE</div>
	<div class="content-block-slinks">

				<div class="slink-title">Future Digital Finance West | Dec 4-5</div>
				<div class="slink-text"><a href="" onclick=" { ENN_ad_wo(10023,'15073286385945'); return false; }" onmouseover="status='https://www.allec.com/events/future-digital-finance-west-70?utm_source=ectnews&amp;utm_medium=stl&amp;utm_campaign=wbr&amp;utm_content=fdfw'; return true;" onmouseout="status=''; return true;"  ><img src="/images/sda/wbr_60x60.jpg" width="60" height="60" border="0" align="right" />
A conference for digital finance innovators who are paving the way forward at America's largest financial institutions. 25% discount to finance execs. View agenda and learn more.</a><img class="ct-10023-1-all_ec_wbrfdfw_stl-1" src="/adsys/count/10023/?nm=1-all_ec_wbrfdfw_stl-1&amp;ENN_rnd=15073286385945&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" /></div>
				

				<div class="slink-title">Deluxe Social Media Management Services</div>
				<div class="slink-text"><a href="" onclick=" { ENN_ad_wo(10000,'15073286385945'); return false; }" onmouseover="status='http://www.shareasale.com/r.cfm?B=931279&amp;U=1533249&amp;M=19875&amp;urllink='; return true;" onmouseout="status=''; return true;"  ><img src="/images/sda/deluxe_60x60.png" width="60" height="60" border="0" align="right" />
We create, manage, and report on your social media presence. Engage your audience. Maximize your reach. Learn more.</a><img class="ct-10000-a-sas-deluxe-stl-1" src="/adsys/count/10000/?nm=a-sas-deluxe-stl-1&amp;ENN_rnd=15073286385945&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" /></div>
				

				<div class="slink-title">Marketers - Fill Your Sales Funnel Instantly</div>
				<div class="slink-text"><a href="" onclick=" { ENN_ad_wo(8781,'15073286385945'); return false; }" onmouseover="status='/shared/sales/ECTNEWS-INSTA-LEADS-DECK.pdf'; return true;" onmouseout="status=''; return true;"  ><img src="/images/sda/sales-funnel_60x60.jpg" width="60" height="60" border="0" align="right" />
Access millions of  IT and business decision makers. Our full-service global marketing program delivers sales-ready leads. Learn more.</a><img class="ct-8781-1-instaleads-stl-1" src="/adsys/count/8781/?nm=1-instaleads-stl-1&amp;ENN_rnd=15073286385945&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" /></div>
				
	</div>
<!-- /slinks -->

	<img class="ct-3217-a_sponsored_links" src="/adsys/count/3217/?nm=a_sponsored_links&amp;ENN_rnd=15073286385945&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 170 crid: 3217:a_sponsored_links cc:us-->
	
	
	<div class="hslice" id="lniheadlines"><a rel="feedurl" href="/shared_cs/navsliceupdate.xhtml" style="display:none;"></a><div class="entry-title" style="display:none">LinuxInsider Headlines</div>

	<div class="content-tab border-lni"><a class="content-block-intro" href="http://www.linuxinsider.com/">LinuxInsider</a></div>
	<div class="content-block">
	
			<div class="headline-item" id="rhd-84859">
			<a href="http://www.linuxinsider.com/story/84859.html" >Hologram Debuts Open Source Cellular Modem for IoT</a>
			</div>
			

			<div class="headline-item" id="rhd-84851">
			<a href="http://www.linuxinsider.com/story/84851.html" >RoboCyberWall Aims to Block Linux Server Hacks</a>
			</div>
			

			<div class="headline-item" id="rhd-84823">
			<a href="http://www.linuxinsider.com/story/84823.html" >ArchLabs Makes Up for Parabola's Curve Balls</a>
			</div>
			

			<div class="headline-item" id="rhd-84847">
			<a href="http://www.linuxinsider.com/story/84847.html" >Microsoft Digs Deeper to Bankroll Open Source Initiative</a>
			</div>
			

			<div class="headline-item" id="rhd-84845">
			<a href="http://www.linuxinsider.com/story/84845.html" >Red Hat, SAP Team on New Integrated Enterprise Linux Platform</a>
			</div>
			

			<div class="headline-item" id="rhd-84834">
			<a href="http://www.linuxinsider.com/story/84834.html" >SQL Server 2017 Embraces Linux, Docker</a>
			</div>
			

			<div class="headline-item" id="rhd-84832">
			<a href="http://www.linuxinsider.com/story/84832.html" >Red Hat Enlarges Its Open Source Patent Promise Umbrella</a>
			</div>
			

			<div class="headline-item" id="rhd-84826">
			<a href="http://www.linuxinsider.com/story/84826.html" >Linux: Come for the Kernel, Stay for the Popcorn</a>
			</div>
			
	</div>

	</div>
	
	<div class="right-bb">
	
	<!--ps: 125 crid: 10033:a-nmg_sep_lin_300-1 cc:us s_c:10032,3217,9888,9876,10045,10033 px:0-->
	<div class="bbframe">
<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 300x250 - Medium Rectangle */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 5).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
</div>
	<img class="ct-10033-a-nmg_sep_lin_300-1" src="/adsys/count/10033/?nm=a-nmg_sep_lin_300-1&amp;ENN_rnd=15073286388717&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 125 crid: 10033:a-nmg_sep_lin_300-1 cc:us-->
	
	</div>

	
<!--/content-nav-->
</div>


</div>



<div id="content-bottom">

<a name="inside-site"></a>

	
	<div id="lb2">
	
	<!--ps: 21 crid: 10032:a-nmg_sep_lin_728-1 cc:us s_c:10032,3217,9888,9876,10045,10033 px:0-->
	<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 728x90 - Leaderboard */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 4).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
	<img class="ct-10032-a-nmg_sep_lin_728-1" src="/adsys/count/10032/?nm=a-nmg_sep_lin_728-1&amp;ENN_rnd=15073286384230&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 21 crid: 10032:a-nmg_sep_lin_728-1 cc:us-->
	
	</div>
	



	
	
	<div id="lb3" class="lb2">
	
	<!--ps: 163 crid: 10032:a-nmg_sep_lin_728-1 cc:us s_c:10032,3217,9888,9876,10045,10033 px:0-->
	<script type="text/javascript"><!--//<![CDATA[
  var ados = ados || {};
  ados.run = ados.run || [];
  /* load placement for account: Neudesic Media Group, site: Linux Insider, size: 728x90 - Leaderboard */
  ados.run.push(function() {
    ados_addInlinePlacement(2072, 758479, 4).setRedirectUrl('-optional-click-macro-').loadInline();
  });
//]]>//--></script>
<script type="text/javascript" src="//static.adzerk.net/ados.js"><!--//<![CDATA[//]]>//--></script>
	<img class="ct-10032-a-nmg_sep_lin_728-1" src="/adsys/count/10032/?nm=a-nmg_sep_lin_728-1&amp;ENN_rnd=15073286382248&amp;ign=0/ign.gif" width="0" height="0" alt="" style="position:absolute; left:0px; top:0px" />
	<!--/ps: 163 crid: 10032:a-nmg_sep_lin_728-1 cc:us-->
	
	</div>
	


</div>
</div>
</div>

<div id="footer-container">
<div id="footer">

	<table class="headlines-section publication-info">
	<tr>
	<td valign="top"><div><a href="http://www.ectnews.com/about/advertising/#publications">Publications</a></div>
	<ul>
	<li><a class="headline" href="https://www.allec.com/">ALL EC</a></li>
	<li><a class="headline" href="http://www.crmbuyer.com/">CRM Buyer</a></li>
	<li><a class="headline" href="http://www.ecommercetimes.com/">E-Commerce Times</a></li>
	<li><a class="headline" href="http://www.linuxinsider.com/">LinuxInsider</a></li>
	<li><a class="headline" href="http://www.technewsworld.com/">TechNewsWorld</a></li>

	</ul>
	<div id="bottom-logo" style="position: absolute;width:455px; height:125px; margin-top:10px"><a href="http://www.ectnews.com/"><img src="/images/2013/enn-logo-bottom.png" align="left" width="455" height="125" border="0" style="margin-left: -5px;" alt="ECT News Network" /></a></div>

	</td>
	<td valign="top" style="padding-left:50px"><div><a href="http://www.ectnews.com/perl/newsletter_registration.pl">Newsletters</a></div>
	<ul>
	<li><a class="headline" href="http://www.ectnews.com/perl/newsletter_registration.pl" onclick='window.open("http://www.ecommercetimes.com/perl/nwsltrdisp.pl?n=ect_daily","_blank","resizable=yes,menubar=yes,location=no,toolbar=no,scrollbars=yes,status=no,directories=no,width=650,height=400"); return false;'>E-Commerce Minute</a></li>
	<li><a class="headline" href="http://www.ectnews.com/perl/newsletter_registration.pl" onclick='window.open("http://www.technewsworld.com/perl/nwsltrdisp.pl?n=tnw_daily","_blank","resizable=yes,menubar=yes,location=no,toolbar=no,scrollbars=yes,status=no,directories=no,width=650,height=400"); return false;'>Tech News Flash</a></li>
	<li><a class="headline" href="http://www.ectnews.com/perl/newsletter_registration.pl" onclick='window.open("http://www.ectnews.com/perl/nwsltrdisp.pl?n=enn_weekly","_blank","resizable=yes,menubar=yes,location=no,toolbar=no,scrollbars=yes,status=no,directories=no,width=650,height=400"); return false;'>ECT News Network Weekly</a></li>
	<li><a class="headline" href="http://www.ectnews.com/perl/newsletter_registration.pl" onclick='window.open("http://www.ectnews.com/perl/nwsltrdisp.pl?n=edpick_alert","_blank","resizable=yes,menubar=yes,location=no,toolbar=no,scrollbars=yes,status=no,directories=no,width=650,height=400"); return false;'>Editor's Pick</a></li>
	<li><a class="headline" href="http://www.ectnews.com/perl/newsletter_registration.pl">Subscribe</a></li>
	</ul>
	</td>

	<td valign="top">
	<div>Reader Services</div>
	<ul>
	<li><a class="headline" href="http://www.ectnews.com/perl/User.pl">Account Management</a></li>
	<li><a class="headline" href="http://www.ectnews.com/perl/board/mboard.pl">Discussion</a></li>
	<li><a class="headline" href="http://www.ectnews.com/about/link-to-us.xhtml">Linking Policy</a></li>
	<li><a class="headline" href="http://www.ectnews.com/about/network_map.xhtml">Network Map</a></li>
	<li><a class="headline" href="http://www.ectnews.com/about/newsalerts/">News Alerts</a></li>
	<li><a class="headline" href="http://www.ectnews.com/about/link-to-us.xhtml#rss">RSS / XML Feeds</a></li>
	<li><a class="headline" href="http://www.ectnews.com/perl/search.pl">Search ECT News Network</a></li>
	</ul>
	<table cellpadding="0" cellspacing="0" border="0">
		<tr>
		<td><a href="https://www.facebook.com/ectnews" target="_blank"><img src="/images/2013/navicon-facebook_20x20-gray.png" width="20" height="20" border="0" alt="Facebook" /></a></td>
		<td><a href="https://www.twitter.com/technewsworld" target="_blank"><img src="/images/2013/navicon-twitter_20x20-gray.png" width="20" height="20" border="0" alt="Twitter" /></a></td>
		<td><a href="http://www.linkedin.com/company/ect-news-network" target="_blank"><img src="/images/2013/navicon-linkedin_20x20-gray.png" width="20" height="20" border="0" alt="LinkedIn" /></a></td>
		<td><a href="https://plus.google.com/108979104378490788701/posts" target="_blank"><img src="/images/2013/navicon-googleplus_20x20-gray.png" width="20" height="20" border="0" alt="Google+" /></a></td>
		<td><a href="http://www.stumbleupon.com/submit" onclick="ENN_wo('http://www.stumbleupon.com/submit?url=' + (typeof ENN_sc_u != 'undefined' ? ENN_sc_u : document.location.href)); return false;" target="_blank"><img src="/images/2013/navicon-stumbleupon_20x20-gray.png" width="20" height="20" border="0" /></a></td>
		<td><a href="http://www.ectnews.com/about/link-to-us.xhtml#rss" target="_blank"><img src="/images/2013/navicon-rss_20x20-gray.png" width="20" height="20" border="0" alt="RSS" /></a></td>
		</tr>
	</table>
	</td>
	<td valign="top" style="padding-left:10px"><div>Company Info</div>
	<ul>
	<li><a class="headline" href="http://www.ectnews.com/about/">About</a></li>
	<li><a class="headline" href="http://www.ectnews.com/about/advertising/">Advertising</a></li>
	<li><a class="headline" href="http://www.ectnews.com/about/bizdev.xhtml">Business Development</a></li>
	<li><a class="headline" href="http://www.ectnews.com/about/careers.xhtml">Careers</a></li>
	<li><a class="headline" href="http://www.ectnews.com/about/#contact">Contact</a></li>
	<li><a class="headline" href="http://www.ectnews.com/about/permissions.xhtml">Permissions</a></li>
	<li><a class="headline" href="http://www.ectnews.com/about/reprints/">Reprint Information</a></li>
	</ul>
	</td>
	</tr>
	</table>
	<div id="bottom-copyright">
		<div style="float:right;">
		<a class="bottom-copyright" href="http://www.ectnews.com/about/terms-of-service.xhtml">Terms of Service</a> | <a class="bottom-copyright" href="http://www.ectnews.com/about/privacy.xhtml">Privacy Policy</a> | <a class="bottom-copyright" href="http://www.ectnews.com/about/advertising/">How To Advertise</a>
		</div>
		Copyright 1998-2017 ECT News Network, Inc. All Rights Reserved.

	</div>
</div>
</div>






<script type="text/javascript">
	(function(){
		window._pxAppId ='PXeL3l4XIH';
		// Custom parameters
		// window._pxParam1 = "<param1>";
		var p = document.getElementsByTagName('script')[0],
			s = document.createElement('script');
		s.async = 1;
		s.src = '//client.perimeterx.net/PXeL3l4XIH/main.min.js';
		p.parentNode.insertBefore(s,p);
	}());
</script>
<div style="position:fixed; top:0; left:0;" width="1" height="1">
	<img src="//collector-PXeL3l4XIH.perimeterx.net/api/v1/collector/pxPixel.gif?appId=PXeL3l4XIH">
	<!-- With custom parameters: -->
	<!--<img src="//collector-PXeL3l4XIH.perimeterx.net/api/v1/collector/pxPixel.gif?appId=PXeL3l4XIH&p1=VALUE&p2=VALUE2&p3=VALUE3">-->
</div>
<noscript>
	<div style="position:fixed; top:0; left:0;" width="1" height="1">
		<img src="//collector-PXeL3l4XIH.perimeterx.net/api/v1/collector/noScript.gif?appId=PXeL3l4XIH">
	</div>
</noscript>
</body>
</html>
